Pontiac Street Performance
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password

 All Forums
 Pontiac Performance
 Restoration & Performance Forum
 Problem with my g6
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

daniel77
Tribal Scout

United Kingdom
3 Posts

Posted - 25 May 2019 :  03:14:47 AM  Show Profile  Reply with Quote
Hello everyone,

I have a 2009 g6. Recently the check engine light has come on. the speedometer wont work but the tach does. http://tradevenue.se/ Also, the odometer says error. On the dash it says power steering but the car turns fine. When you flip through using the info button on the dash https://www.7zip.vip/ everything is blank except oil life and tire pressure. https://www.applock.ooo/ I went to the local auto store to see what codes it was throwing out but thier scanner wont connect. I tried 3 place all with no luck. Also the car is hesitant to start but it will and it shifts hard. I need help!


Edited by - daniel77 on 09 Jan 2020 05:04:02 AM

johnrich
Tribal Scout

1 Posts

Posted - 07 Aug 2019 :  12:43:09 PM  Show Profile  Reply with Quote

Hello everyone,

I have a 2009 g6. Recently the check engine light has come on. the speedometer wont work but the tach does. https://baclinc.com/seo-mumbai Also, the odometer says error. On the dash it says power steering https://radrdetector.com/best-radar-detector-reviews/ but the car turns fine. When you flip through using the info button on the dash https://www.techavy.com/kickass-proxy-kat-unblocked/ everything is blank except oil life and tire pressure. I went to the local auto store to see what https://www.newsesp.com/best-ssd-for-gaming/ codes it was throwing out but thier scanner wont connect. I tried 3 place all with no luck. Also the car is hesitant to start but it will and it shifts hard. I need help!
Go to Top of Page

Brian Baker
Mongo

USA
1067 Posts

Posted - 09 Jan 2020 :  11:19:32 PM  Show Profile  Reply with Quote
I'll throw my 2 cents in:

Speedometers in cars these days are wire driven, not cable driven. I suspect your odometer error and speedometer not functioning are related, and it's probably the sender at the transmission that is the culprit.

Check the fluid level in your power steering pump reservoir and make sure it is full. If it is and the car is steering fine and not making any whining noises when you turn the wheel, it is probably just a sensor gone bad. Do these things have a fluid level sensor? I don't know.

Can't get an OBD-II code reader to connect with computer? Are you sure they're entering in the correct year, make, model, engine for the car into the reader? Let's get a code reader on there before looking at why it starts hard and shifts hard.

Will Rogers never met a liberal.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Pontiac Street Performance © 2006-2019 Go To Top Of Page
This page was generated in 0.03 seconds. This Site Sponsored By:
Powered By: Snitz Forums 2000 Version 3.4.05